Author Topic: My feedback on 0.97 RC1  (Read 8988 times)

Offline icemanu

  • User
  • *
  • Posts: 11
    • View Profile
My feedback on 0.97 RC1
« on: July 20, 2006, 07:05:46 PM »
Hello. Your program is great.

A couple of things :
I've written the language.php file for the french language (with utf-8 in the config.inc.php), but the accentuation encoding gets weird (Privé instead of Privé, for example).
The moving content feature : in the popup window, i see "close(); ?>" (not closed tag probably).
Can you explain more about the rights. I fruitlessly try to understand how to set the rights. For example,  i want to grant RW access to a user for a subtree and ReadOnly  for another to that same subtree.
And what means "set recursiv?" and why is it impossible to modify ?
Emmanuel.

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: My feedback on 0.97 RC1
« Reply #1 on: July 20, 2006, 07:40:09 PM »
Hello,

cool that you made a translation for french. Can you send me that file? I will check that with utf-8!

I will check that with the popup!

Knowledgeroot has a projectpage now: www.knowledgeroot.de
I have written a text to rights in knowledgeroot: http://www.knowledgeroot.de/index.php?id=14

You can read that. I hope you understand rights after reading that.

"set recursiv" means if you check this: all subpages of this page and all contents on this page and on the subpages will inherit the rights you set at this point! Its the same as you use in linux with "chmod 755 folder -R".

If you have more questions you can ask me :)

regards,
Frank

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: My feedback on 0.97 RC1
« Reply #2 on: July 20, 2006, 08:32:24 PM »
OK.

Thanks for the translation.

I have no problem with the translation. Have you set utf8 as charset in configfile?
$CONFIG['knowledgeroot']['charset'] = "utf8";

I use firefox and i have no problems. Do you use IE?

Frank

Offline icemanu

  • User
  • *
  • Posts: 11
    • View Profile
Re: My feedback on 0.97 RC1
« Reply #3 on: July 21, 2006, 12:50:29 PM »
Hello,

About the encoding:

Yes, the charset encoding is left untouched (utf8) in my config file.

* in IE, it is good, no encoding problem when setting is : automatic detection (in this case, it is set to "western europe (windows)" and not "unicode (utf-8)", strange isn't it ?)

* in Firefox, it is not good : With automatic detection, it is set to "unicode (utf-8)". The static labels from language file are bad when accentuation or cedilla.

And when i create a page in FF, label with accentuation is good in the tree. Then i go back to IE and see the label bad.

Do you also have "western europe (windows)" in IE ?

By the way, i'm under WAMP.
Thank you.
« Last Edit: July 21, 2006, 01:48:19 PM by icemanu »

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: My feedback on 0.97 RC1
« Reply #4 on: July 21, 2006, 11:44:01 PM »
Hi,

i have changed the following in knowledgeroot:
the htmlrequestheader will be set with the charset in the config file!

I hope this will be the solution.
It is now in the CVS Version. In the middle of next week i will release the RC2 with the fixes!

One thing left. I think its normal if you write content in one browser with charset utf8 that it will be look bad in other browser with charset western or something else. I hope with my changed will the automatic charset switch work.

regards,
Frank