Author Topic: How to change WYSIWYG  (Read 10637 times)

Offline fuk

  • User
  • *
  • Posts: 24
    • View Profile
How to change WYSIWYG
« on: October 05, 2011, 01:41:11 PM »
Please, where to change wysiwyg editor from fck to tinymce?
Thx, Fuk

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: How to change WYSIWYG
« Reply #1 on: October 05, 2011, 02:47:56 PM »
Hi,

you can disable the fckeditor in the extension manager in the admin interface and install/enable the other extension.

Frank

Offline fuk

  • User
  • *
  • Posts: 24
    • View Profile
Re: How to change WYSIWYG
« Reply #2 on: October 06, 2011, 12:45:18 PM »
Thanks, but can you be more concrate? Or is somewhere on the KR web some documentation about how to use extensions (unfortunetly I can not find any)?
If I login to admin interface, I proved to disable dojo editor but if I choose import, I have empty repository list and I can not find any .krx file. Should I download TineMCE from somewhere and than install it?
TF

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: How to change WYSIWYG
« Reply #3 on: October 06, 2011, 07:51:06 PM »
Hi,

i will try to explain.
In admin interface you have a menu "extensions" and a submenu "import".
If you go to extensions. You will see all extensions that are available for install or you can enable or disable it.
At import menu you can upload an extension directly or you can import it from an extension repository.

For manual extension download go to http://knowledgeroot.org/extensions.html to download the extension yourself.
If you want to download it from extension repository you must click the "update repository list" button at the import menu.

So, easy way in my eyes are to update from repository and import an extension.
After that you can install it and enable it.

Ok. Some specials for editors.
You can install and enable more than one editor extension but only one editor will be available. So be sure to enable only one editor at time.

Does this explanation help?

regards,
Frank

Offline fuk

  • User
  • *
  • Posts: 24
    • View Profile
Re: How to change WYSIWYG
« Reply #4 on: October 07, 2011, 06:51:27 AM »
Thanks for detailed explanation. But if I choose "update repository list" I will get error "could not connect to repository server". I have checked proxy, connection, everything works.
KR version 1.0.2, tested in Firefox 7, IE8, IE9.
Any help?
TF

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: How to change WYSIWYG
« Reply #5 on: October 07, 2011, 07:37:09 PM »
Hi,

so you must use a proxy to come out to internet?
A proxy connection is not implemented at the moment.
So you must download the extension directly from knowledgeroot.org

Frank

Offline fuk

  • User
  • *
  • Posts: 24
    • View Profile
Re: How to change WYSIWYG
« Reply #6 on: October 10, 2011, 07:09:51 AM »
I have downloaded tinymce_3.4.2.krx, installed and enabled it (+ disabled DOJO). (extensions.jpg attached)

Unfortunately in frontend tinymce is not active (neither dojo). (frontend.jpg attached)

TF

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: How to change WYSIWYG
« Reply #7 on: October 10, 2011, 07:49:46 PM »
Hi,

sounds strange. Did you have some javascript errors?
Did you see dojo or tinymce javscript code in the generated source code?

Frank

Offline fuk

  • User
  • *
  • Posts: 24
    • View Profile
Re: How to change WYSIWYG
« Reply #8 on: October 11, 2011, 06:33:00 AM »
Yes, some errors (seen in IE8, not in IE9 or Firerfox).

Podrobnosti o chybě na webové stránce

Uživatel zástupce: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Časové razítko: Tue, 11 Oct 2011 05:19:36 UTC


Zpráva: 'tinyMCE_GZ' není definováno.
Řádek: 22
Znak: 4
Kód: 0
Identifikátor URI: http://192.1.1.18/kb-test/index.php?id=12&eid=114


Zpráva: 'tinymce' není definováno.
Řádek: 32
Znak: 4
Kód: 0
Identifikátor URI: http://192.1.1.18/kb-test/index.php?id=12&eid=114


Zpráva: Neplatný argument
Řádek: 370
Znak: 1
Kód: 0
Identifikátor URI: http://192.1.1.18/kb-test/index.php?id=12&eid=114

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: How to change WYSIWYG
« Reply #9 on: October 12, 2011, 09:57:33 PM »
Hi,

could you give me the english version of these errors?! ;)

And could you give me the generated html source.
Sounds like some javascript code could not be loaded.

Perhaps, could you try it in another language?!

Frank

Offline fuk

  • User
  • *
  • Posts: 24
    • View Profile
Re: How to change WYSIWYG
« Reply #10 on: October 13, 2011, 09:19:57 AM »
So, after some testing.. everything works.
I tried to make a clean install and tinymce works well.
So I made DB backup and make a new installation of my KR and now extensions (tinymce included) work well.

Thanks for help!
TF