Author Topic: Errors running install.php  (Read 7328 times)

Offline crazyn3wf

  • User
  • *
  • Posts: 2
    • View Profile
Errors running install.php
« on: September 27, 2011, 06:13:39 PM »
Hi,

After filling out the info in install.php Apache throws the following error.

[Tue Sep 27 11:06:21 2011] [error] [client 10.10.56.1] PHP Fatal error:  Uncaught exception 'Zend_Config_Exception' with message 'syntax error, unexpected '!' in config/app.ini.dist on line 28\n' in /var/www/kr/lib/Zend/Config/Ini.php:182\nStack trace:\n#0 /var/www/kr/lib/Zend/Config/Ini.php(202): Zend_Config_Ini->_parseIniFile('config/app.ini....')\n#1 /var/www/kr/lib/Zend/Config/Ini.php(126): Zend_Config_Ini->_loadIniFile('config/app.ini....')\n#2 /var/www/kr/include/class-knowledgeroot-installer.php(235): Zend_Config_Ini->__construct('config/app.ini....', NULL, Array)\n#3 /var/www/kr/include/class-knowledgeroot-installer.php(62): knowledgeroot_installer->doInstall()\n#4 /var/www/kr/install.php(36): knowledgeroot_installer->mainInstall()\n#5 {main}\n  thrown in /var/www/kr/lib/Zend/Config/Ini.php on line 182, referer: http://fernie.domain.local/kr/install.php
[Tue Sep 27 11:06:21 2011] [error] [client 10.10.56.1] File does not exist: /var/www/kr/system/javascript/dojo/dijit/form/nls/en, referer: http://fernie.domain.local/kr/install.php
[Tue Sep 27 11:06:21 2011] [error] [client 10.10.56.1] File does not exist: /var/www/kr/system/javascript/dojo/dijit/form/nls/en-ca, referer: http://fernie.domain.local/kr/install.php

Offline crazyn3wf

  • User
  • *
  • Posts: 2
    • View Profile
Re: Errors running install.php
« Reply #1 on: September 27, 2011, 06:20:38 PM »
Never Mind, seems to be a bug that wont allow special characters in the password. After removing the Special characters it worked fine.

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: Errors running install.php
« Reply #2 on: September 27, 2011, 06:46:46 PM »
Hi,

did you know what special character is making the problem? Otherwise i must check "all" special characters.

Which php version did you use?

regards,
Frank