Author Topic: tinyMCE << problem  (Read 7251 times)

Offline Raboo

  • User
  • *
  • Posts: 21
    • View Profile
    • LetIT Hosted Exchange
tinyMCE << problem
« on: September 06, 2011, 10:07:13 AM »
Hi,

I have a problem with the '<' sign on tinyMCE and the other graphical editors.
For instance i can create a content with:
Code: [Select]
cat >/etc/yum.repos.d/vmware-tools.repo<<EOF
[vmware-tools]
name=VMware Tools
baseurl=http://packages.vmware.com/tools/esx/4.1latest/rhel6/`uname -p`
enabled=1
gpgcheck=1
EOF

But after when i'm going to edit the page again parts of the original content is invisible.. I can still read the content. But i cannot edit it because all the invisible stuff will dissapear.
I've deducted that it got to do with the << or <<EOF

Is this a ckeditor, fckeditor, tinyMCE problem or a knowledegeroot problem?
Does anyone have a fix?

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: tinyMCE << problem
« Reply #1 on: September 06, 2011, 10:16:36 AM »
Hi,

i must take a deeper look.
But it seems that the dojo rte has the same problems. I think this is a rte problem and not a knowledgeroot problem itself.
I will check that and will give you feedback.

Frank

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: tinyMCE << problem
« Reply #2 on: September 09, 2011, 02:14:40 PM »
Hi,

i took a first look on this.
fckeditor works fine for me. But dojo rte, tinymce or ckeditor does not work as expected.
I could not resolve why this is a problem.
But it seems to work if you use pre tags around the "code" part.

I will search for a solution for that and will give you feedback.

Frank

Offline Raboo

  • User
  • *
  • Posts: 21
    • View Profile
    • LetIT Hosted Exchange
Re: tinyMCE << problem
« Reply #3 on: September 09, 2011, 02:38:59 PM »
I am using a pre tag. I have added a syntax higlighter plugin for tinymce, which itself adds a pre tag.

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: tinyMCE << problem
« Reply #4 on: September 12, 2011, 12:56:02 PM »
Hi,

i could not found any solution at the moment.
I opened a bugreport at tinymce at the moment to clear this.

Frank

Offline Raboo

  • User
  • *
  • Posts: 21
    • View Profile
    • LetIT Hosted Exchange
Re: tinyMCE << problem
« Reply #5 on: September 12, 2011, 01:01:43 PM »
Ok, thanks!