Author Topic: ROOT -> Artikelanlegen geht nicht  (Read 11859 times)

subSTYLE

  • Guest
ROOT -> Artikelanlegen geht nicht
« on: November 05, 2005, 08:26:47 PM »
Hallo !

ich habe kbTree auf Apache/2.0.55 (Win32) mit PHP/5.0.5
verucht zum laufen zu bringen.

Es ist eine lokale Intsallation.

Leider kann ich zwar auf "ROOT" klicken, es passiert jedoch leider
nichts. Ich bekomme keine Seite angezeigt :(

Woran kann es liegen ?

Grüße aus Bremen

subby

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: ROOT -> Artikelanlegen geht nicht
« Reply #1 on: November 07, 2005, 09:05:02 AM »
Hi

welche Version von knowledgeroot setzt du ein und welche Datenbank benutzt du?

mfg Frank

subSTYLE

  • Guest
Re: ROOT -> Artikelanlegen geht nicht
« Reply #2 on: November 07, 2005, 08:14:53 PM »
Hallo Frank,

ich habe mySQL 5.0.15-nt im Einsatz.
Die knowledgeroot version ist das aktuellste release knowledgeroot 0.9.5a.

Zum installieren nutze ich das SQL4 dumpfle, soweit ich sehen kann gibt es
dort keine Fehler:

Code: [Select]
SQL-Befehl:
CREATE TABLE `content` (
`id` int( 11 ) NOT NULL AUTO_INCREMENT ,
`belongs_to` int( 11 ) NOT NULL default '0',
`content` text NOT NULL ,
PRIMARY KEY ( `id` )
);# MySQL lieferte ein leeres Resultat zurück (d.h. null Zeilen).
CREATE TABLE `files` (
`id` int( 11 ) NOT NULL AUTO_INCREMENT ,
`belongs_to` int( 11 ) default NULL ,
`file` blob,
`filename` varchar( 255 ) default NULL ,
`filesize` int( 11 ) default NULL ,
`filetype` varchar( 255 ) default 'application/octet-stream',
PRIMARY KEY ( `id` )
);# MySQL lieferte ein leeres Resultat zurück (d.h. null Zeilen).
CREATE TABLE `tree` (
`id` int( 11 ) NOT NULL AUTO_INCREMENT ,
`belongs_to` int( 11 ) NOT NULL default '0',
`title` varchar( 255 ) NOT NULL default '',
`visible` int( 1 ) NOT NULL default '0',
PRIMARY KEY ( `id` )
);# MySQL lieferte ein leeres Resultat zurück (d.h. null Zeilen).
ALTER TABLE `tree` ADD INDEX ( `belongs_to` ) ;# MySQL lieferte ein leeres Resultat zurück (d.h. null Zeilen).
ALTER TABLE `content` ADD INDEX ( `belongs_to` ) ;# MySQL lieferte ein leeres Resultat zurück (d.h. null Zeilen).
ALTER TABLE `files` ADD INDEX ( `belongs_to` ) ;# MySQL lieferte ein leeres Resultat zurück (d.h. null Zeilen).
INSERT INTO `tree` ( `id` , `belongs_to` , `title` , `visible` )
VALUES ( 0, 0, 'ROOT', 1 ) ;# Betroffene Datensätze: 1


Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: ROOT -> Artikelanlegen geht nicht
« Reply #3 on: November 08, 2005, 09:41:09 AM »
Hi,

hab den fehler schon geahnt.

Es gibt eine neuere Version von Knowledgeroot! Hier der Link
http://www.linuxdelta.de/uploads/media/knowledgeroot-0.9.5b.tar.gz

Einfach runterladen und die SQL-Datei von dort nochmal einspielen.

Dann sollte es funktionieren. Es gab dort fehler bei der groß und kleinschreibung!

Sorry. Hoffe das war dann auch der Fehler.

Siehe auch:
http://www.linuxdelta.de/index.php?id=144&backPID=144&tt_news=144

mfg Frank

subSTYLE

  • Guest
Re: ROOT -> Artikelanlegen geht nicht
« Reply #4 on: November 09, 2005, 07:47:22 PM »
Hallo !

Ich habe die Version nochmal neu installiert. Leider klappt es noch immer nicht :(
Es bleibt bei dem schon beschriebenen Phenomen.

Vielleicht noch Lösungsansätze ? Kann ich irgendwie beim debuggen helfen ?

Grüße

subby

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: ROOT -> Artikelanlegen geht nicht
« Reply #5 on: November 10, 2005, 08:52:32 AM »
Hi

also wenn du den neuen SQL-Dump eingespielt hast und es immernoch nicht funktioniert würde ich sagen das du mal nen dump von deiner datenbank machst und mir den zuschickst mit der config und den dateien.

ok?

am besten dann an lordlamer@lordlamer.de schicken!

sorry wenn ich nur so tagsüber antworten kann. hab noch kein inet zu hause ;) bin grad erst umgezogen

mfg frank

subSTYLE

  • Guest
Re: ROOT -> Artikelanlegen geht nicht
« Reply #6 on: November 10, 2005, 11:39:32 AM »
Hallo ! Die mail ist raus !

Grüße

subby

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 694
    • View Profile
    • http://www.lordlamer.de
Re: ROOT -> Artikelanlegen geht nicht
« Reply #7 on: November 10, 2005, 12:49:00 PM »
Hi

also ich hab sie bekommen und werde das dann nochmal testen mit den daten die du mir zugeschickt hast.

mfg frank