Author Topic: KR 1.0.1 Lange Ladezeiten  (Read 10413 times)

Offline Willi

  • User
  • *
  • Posts: 42
    • View Profile
KR 1.0.1 Lange Ladezeiten
« on: June 28, 2011, 01:44:11 PM »
Hi Frank,
KR 1.0.1 hat auf Seiten mit mehreren Inhalten sehr lange Ladezeiten. Internet Explorer 8 bringt nach ca 40 Sekunden FM Ausführung des Skripts abbrechen?

Beim klick auf Ja werden die Inhalte teilweise aufgeklappt angezeigt. Beim klick auf nein wird nochmal ca 40 Sekunden geladen. Anschließend werden alle Inhalte wie es sein sollte zusammengeklappt angezeigt.
Fire Fox bringt keine Meldung aber die Ladezeiten sind ebenso lang.
Obwohl ich die Seiten so konfiguriert habe das alle Inhalte zusammengeklappt angezeigt werden sollen sehe ich beim Laden der Seite die Inhalte ausgeklappt. Vielleicht ist dieser Umstand für die langen Ladezeiten verantwortlich.
Viele Grüße Willi
« Last Edit: June 28, 2011, 02:22:54 PM by Willi »

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 688
    • View Profile
    • http://www.lordlamer.de
Re: KR 1.0.1 Lange Ladezeiten
« Reply #1 on: June 28, 2011, 07:21:52 PM »
Hi,

*puh* ausm Bauch raus kann ich dazu so leider nichts sagen. Dafür musst du mir etwas mehr über deine Umgebung erzählen.
Wo läuft Knowledgeroot? Welches Betriebssystem? Welche PHP Version? Welche Datenbank und welche Version?
Wie greifst du auf Knowledgeroot zu? Lokal? Internet?
Vielleicht können wir das eventuell etwas eingrenzen damit.

Probier auch mal bitte folgende URL aus:
http://download.dojotoolkit.org/release-1.6.1/dojo-release-1.6.1/dijit/themes/themeTester.html

Das ist ne Dojo Testseite. Hast du da auch die Performanceprobleme?

Gruß
Frank

Offline Willi

  • User
  • *
  • Posts: 42
    • View Profile
Re: KR 1.0.1 Lange Ladezeiten
« Reply #2 on: July 01, 2011, 11:33:34 AM »
Hi Frank,
PHP Version: 5.2.5
OS: windows 2003 Server enterprise edition
Server Software: Apache/2.2.8 (Win32) PHP/5.2.5

MySQL:
Server: localhost via TCP/IP
Server Version: 5.0.45-community-nt
Protokoll-Version: 10
MySQL-Zeichensatz: UTF-8 Unicode (utf8)
MySQL-Client-Version: 5.0.45

Wir nutzen KR im Intranet.
Mit der Dojo Testseite habe ich keine Probleme.
Viele Grüße
willi
« Last Edit: July 01, 2011, 02:48:37 PM by Willi »

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 688
    • View Profile
    • http://www.lordlamer.de
Re: KR 1.0.1 Lange Ladezeiten
« Reply #3 on: July 01, 2011, 04:19:10 PM »
Hi,

jetzt könnte/sollte man folgende Sachen prüfen.
In firefox selber kann man mit firebug die Ladezeiten sehr gut messen.
Da könnte man mal gucken was da so lange dauert.

Auf dem Server selber könnte man noch gucken ob im apache die module expires und defalte aktiv ist.
Das sollte auch nochmal was bringen.

Gruß
Frank

Offline c46353

  • User
  • *
  • Posts: 29
    • View Profile
Re: KR 1.0.1 Lange Ladezeiten
« Reply #4 on: July 04, 2011, 12:00:27 PM »
Hallo zusammen,

die Module deflate und expires waren nicht aktiv.
Ich hab die jetzt aktiviert und natürlich einen Stop/Start des Apache Services durchgeführt.
Unter IE8 hat sich mal nichts getan. Ladezeiten (bei grösseren Datenmengen) immer noch gruselig im Vergleich zu 0.9.9
Unter FireFox (3.6.17) dauerts auch, aber geht dann zumindest ohne Timeout Abfrage.
Das wars denn mal nicht.
Eventuell sollten wir dir mal einen Dump unser MySQL DB zippen und (wo auch immer) ablegen.
Dann lässt sich das ganze evtl. besser nachvollziehen.

Gruß

Peter

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 688
    • View Profile
    • http://www.lordlamer.de
Re: KR 1.0.1 Lange Ladezeiten
« Reply #5 on: July 04, 2011, 12:02:25 PM »
Hi,

das mit dem Dump wär natürlich super wenn das ginge!

Auf nem Windows 2003 kann ich das dann ja auch nochmal testen.

Gruß
Frank

Offline Willi

  • User
  • *
  • Posts: 42
    • View Profile
Re: KR 1.0.1 Lange Ladezeiten
« Reply #6 on: July 06, 2011, 12:23:18 PM »
Hallo Frank,
wie kann ich dir den Dump zur Verfügung stellen?
Viele Grüße
Willi

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 688
    • View Profile
    • http://www.lordlamer.de
Re: KR 1.0.1 Lange Ladezeiten
« Reply #7 on: July 06, 2011, 12:43:14 PM »
Hi,

eigentlich wie du möchtest. Falls du nichts hast wo du es hinpacken kannst kann ich dir nen FTP Account einrichten.

Gruß
Frank

Offline Willi

  • User
  • *
  • Posts: 42
    • View Profile
Re: KR 1.0.1 Lange Ladezeiten
« Reply #8 on: July 07, 2011, 12:50:53 PM »
Hi Frank,
ich habe dir den Dump via Mail an  deine Lordlamer Adresse gesendet.
Viele Grüße
Willi

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 688
    • View Profile
    • http://www.lordlamer.de
Re: KR 1.0.1 Lange Ladezeiten
« Reply #9 on: July 07, 2011, 01:00:29 PM »
Hi,

jo ist grad angekommen.
Ich teste das dann heute Abend mal.

Gruß
Frank

Offline Willi

  • User
  • *
  • Posts: 42
    • View Profile
Re: KR 1.0.1 Lange Ladezeiten
« Reply #10 on: July 18, 2011, 10:33:32 AM »
Hallo Frank,
gibt es schon was neues zu dem Thema?
Viele Grüße
Willi

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 688
    • View Profile
    • http://www.lordlamer.de
Re: KR 1.0.1 Lange Ladezeiten
« Reply #11 on: July 18, 2011, 10:39:55 AM »
Hi,

jaein ;)
Also Grundsätzlich wird es in Zukunft die Möglichkeit geben Dojo über CDNs zu beziehen. Ausserdem muss ich bei einem Offiziellem Build die Originalquellen von Dojo einbinden anstatt die Sourcen aus dem svn.
Das ansich sollte schonmal unabhängig vom Browser etwas bringen.

Das wird aber wohl nicht bei unserem Problem helfen.
Da bin ich gerade beim testen. Bisher wird ja alles als HTML generiert und dann durch den DojoParser zu diesen tollen DojoWidgets umgewandelt. Das dürfte das eigentlich Problem im IE sein, dass er sich hier aufhängt bei sehr vielen Elementen. So und nun bin ich beim prüfen ob die Inhaltselemente direkt als Javascript erstellen lasse. Das soll wohl des Rätsels Lösung sein. Muss ich aber noch testen. Ausserdem muss ich dann auch sicherstellen, dass die Inhalte darüber dann auch gleich aussehen ;)

Ich bin aber am Ball und geb dir dann weiter Rückmeldung.

Gruß
Frank

Offline Willi

  • User
  • *
  • Posts: 42
    • View Profile
Re: KR 1.0.1 Lange Ladezeiten
« Reply #12 on: July 18, 2011, 12:15:28 PM »
Verstehe zwar nur die Hälfte, aber die Hoffnung stirbt zuletzt. :-)

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 688
    • View Profile
    • http://www.lordlamer.de
Re: KR 1.0.1 Lange Ladezeiten
« Reply #13 on: July 18, 2011, 07:39:31 PM »
Hiho,

kurzes Feedback. Ich hab das jetzt probiert über den Javascript weg wie beschrieben. Das scheint damit deutlich besser zu laufen.
Ich mach mich dann mal an die Umsetzung ;)

Gruß
Frank

Offline admin

  • Administrator
  • User
  • *****
  • Posts: 688
    • View Profile
    • http://www.lordlamer.de
Re: KR 1.0.1 Lange Ladezeiten
« Reply #14 on: July 20, 2011, 02:07:56 PM »
Hiho,

weiteres Feedback. Das was ich bisher umgesetzt habe sieht soweit schonmal gut aus und hat den gewünschten Erfolg im IE gebracht.

Ich lasse dir bei gelegenheit nochmal 2 Dateien dann zukommen zum testen. Dann kannst du das nochmal gegenprüfen und ich würde das dann alles in den Trunk einspielen und auch eine KR 1.0.2 erstellen.

Gruß
Frank