Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - admin

Pages: [1] 2 3 ... 46
1
Knowledgeroot / Re: No content here. in 1.0.3
« on: September 12, 2016, 09:13:45 AM »
Hi,

you have no benefit at the moment if you are using the git repository.
I have removed the javascript dojo part and try to implement all with bootstrap now.
So i need some time to get it working again.

Frank

2
Knowledgeroot / Re: No content here. in 1.0.3
« on: September 12, 2016, 08:19:56 AM »
Hi,

try to use this link:
http://download.lordlamer.de/knowledgeroot/knowledgeroot-1.0.4.tar.gz

Do not use the git repository for the moment.
It is in development. I try to remove dojo and use a database abstraction layer.

regards,
Frank

3
Knowledgeroot / Re: No content here. in 1.0.3
« on: September 08, 2016, 08:14:08 PM »
Hi,

ok for me it is working now.
I used the git repository that was broken.
So where did you download knowledgeroot?

Perhaps, did you see any javascript errors in firefox?

Frank

4
Knowledgeroot / Re: No content here. in 1.0.3
« on: September 08, 2016, 08:13:39 AM »
Hi,

short status update:
Firefox on linux with php5.6/php7 is working fine.
With firefox on windows i have the same problems.
I hope to find the problem today.

Frank

5
Knowledgeroot / Re: No content here. in 1.0.3
« on: September 04, 2016, 10:53:39 PM »
Hi,

i could reproduce your error.
I need to take a deeper look.
Seems to be a javascript problem.

Frank

6
Knowledgeroot / Re: No content here. in 1.0.3
« on: September 01, 2016, 09:14:53 PM »
Hi,

can you create a backup dump of the database itself?

Frank

7
Knowledgeroot / Re: No content here. in 1.0.3
« on: August 31, 2016, 09:01:39 PM »
Hi,

which os, php, mysql version are you using?
Is it possible that you create a dump of the structure from your database?

regards,
Frank

8
Knowledgeroot / Re: How to setup default rights for register users
« on: May 21, 2016, 08:37:59 PM »
Hi,

i think you must change the value for "othergroups" to your needs.
Hope this helps.

Frank

9
Knowledgeroot / Re: How to setup default rights for register users
« on: May 20, 2016, 10:18:42 PM »
Hiho,

you should found an config.php in the extension folder itself.
Path should be: knowledgeroot/extension/register/config.php

In this config file you can define all what you want.
The default file should be look like this:
Code: [Select]
<?php
$CONF 
= array (
        
"cssfile" => "system/extension/register/extension-register.css",

        
"enabled" => "1",
        
"defaultgroup" => "2"// id for the default group - admin: 1, users: 2 (should be default)
        
"othergroups" => "1,90"// comma seperate list of ids for other groups
        
"defaultrights" => "220",
        
"admin" => "0",
        
"rightedit" => "0",
        
"theme" => "",
        
"language" => "en",
        
"requiredpasswordlength" => "5",
);
?>


So you could change the settings to your need.

Hope this will help.

regards,
Frank

10
Hi,

which exact version of php are you using?

As i found out the extion will be tried to move to upload folder.
The path can be found in the config in section upload.
Please try to set the rights to 777 on this folder and try it again please.

Frank

11
Knowledgeroot / Re: SQL Backup and Recovery mit phpMyAdmin
« on: February 05, 2015, 11:15:50 PM »
Hi,

hast du die Möglichkeit das Dump über die Shell zu machen?
Eventuell musst du in phpmyadmin auf latin1 als Zeichensatz wechseln damit das richtig funktioniert.

Gruß
Frank

12
Hi,

also ckeditor funktioniert nicht weil er die Datei:
http://ipc/kr_new_512/extension/ckeditor/ckeditor/ckeditor.js
nicht laden kann. Kannst du das bei dir mal prüfen ob die Datei vorhanden ist?!

Wieso Dojo bei dir nicht will ist mir erst mal noch nicht klar.

Frank

13
Hallo Peter,

wie hast du es denn jetzt zum laufen bekommen?

Was deinen Fehler angeht. Hier müsstest du mal die Javascriptconsole prüfen ob diese Fehler schmeißt.
Oder am besten mit Firefox und Firebug prüfen ob es Fehler bezüglich Javascript gibt oder ob Resourcen nicht geladen werden können.

Gruß
Frank

14
Hi,

zieh dir mal die class-db-core.php von hier bitte:
https://raw.githubusercontent.com/lordlamer/knowledgeroot1/master/include/class-db-core.php
Damit sollten die ersten beiden Fehler weg sein.

Ich weiß wieso die Aliase nicht gehen. Das liegt daran, dass der IIS die htaccess nicht verarbeiten kann. Diese regelt im Apache die Rewrites damit die Aliase gehen.
Ich bin mir jetzt nicht sicher wie das im IIS geht mit den Rewrites. Es geht. Aber ich weiß nicht wie. Das heißt, entweder guckst du da selber oder nutzt keine Aliase oder du installierst den Apache ;)

Hoffe das hilft soweit.
Frank

15
Hi,

welche PHP Version ist das jetzt genau?
Die beiden ersten Fehler bekomme ich glaube ich fix gefixt bei dir.
Fehler 3 und 4 ist dann ein Folgefehler.

Für die Fehler in der index.php auf Zeile 181, 191, 200, 209 müsstest du mir mal die Zeilen zeigen.

Eventuell solltest du in der php.ini noch irgendwie ne error log aktivieren oder in die IIS Error log schauen was da zu dem Fehler 500 steht.

Frank

Pages: [1] 2 3 ... 46