Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - zking2000

Pages: [1]
Knowledgeroot / Re: How to setup default rights for register users
« on: May 21, 2016, 08:47:01 AM »
Hi Frank,

Thanks for your reply.

I modified config.php as below

$CONF = array (
        "cssfile" => "system/extension/register/extension-register.css",

        "enabled" => "1",
        "defaultgroup" => "2", // id for the default group - admin: 1, users: 2 (should be default)
        "othergroups" => "1,90", // comma seperate list of ids for other groups
        "defaultrights" => "111",
        "admin" => "0",
        "rightedit" => "0",
        "theme" => "wordpress",
        "language" => "en",
        "requiredpasswordlength" => "6",

but unfortuantely the problem still can't be resolved.

I found the reason is group as red marked in attached snapshot. the default is admin. if i change to  users, all outputs turns to what i want. and i can't find "group" setting in config.php So could you please let me know how to change "groups" in file? Thanks

Knowledgeroot / How to setup default rights for register users
« on: May 20, 2016, 08:50:30 PM »
Hi Expert,

I enabled the extension "class for registering users" and let users to register the system. But i found all new register users have read+write rights as default. i checked at backend that the default rights going to "admin". So my question is how to set the default rights to "user"? Thanks

Yes. it is the root cause. Issue is resolved now. Thanks


I have an issue when import extention to backend of knowledgeroot.

error message shows on left top of page that "cannot move to cache". snapshot as attahed.

In meantime i can't find the extension which i want to upload just now.

Kindly guide me how to solve this problem. Thanks

My system:
Ubuntu 14.04, Apache2, PHP5, Mysql, knowledgeroot 1.0.4

i set rights for cache folder as 777

Pages: [1]